ComponentSpace

Forums



Old application not working with MFA enabled


Old application not working with MFA enabled

Author
Message
drcmptrman
drcmptrman
New Member
New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)New Member (2 reputation)

Group: Forum Members
Posts: 1, Visits: 4
I'm sure I know the answer to this question, but I thought I would ask here anyway. My team inherited a .net app that uses ComponentSpace and does saml impersonation with Okta. We have started testing MFA and notice that the app no longer works for any users in our test MFA  group. I assume since MFA requires extra authentication via a code, there is no way to mimic that in the application. Is there a workaround?
ComponentSpace
ComponentSpace
ComponentSpace Development
ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)ComponentSpace Development (3.8K reputation)

Group: Administrators
Posts: 2.7K, Visits: 8.4K
The MFA should be handled entirely within Okta. Exactly how the user is authenticated at the identity provider (ie Okta) shouldn't impact the service provider (ie your ASP.NET application).

Please provide more details regarding the issue.

After completing MFA, does control return to your application?

If so, what happens next? Is an exception being thrown? What's the stack trace? 

Regards
ComponentSpace Development
GO


Similar Topics


Execution: 0.000. 2 queries. Compression Enabled.
Login
Existing Account
Email Address:


Password:


Social Logins

Select a Forum....









Forums, Documentation & Knowledge Base - ComponentSpace


Search